magellan roadmate 700...freezing up

Discussion in 'Magellan' started by frankpba524@yahoo.com, Jul 14, 2005.

  1. Guest

    I love my RM700..but i am on my second unit in less than 24 days.
    Both units freeze up(usually while on the 3d turning screen..but not
    always...I e mailed Magellan about the problem with my first unit and
    they gave me a Return Authorization number and told me to send it to
    them for repairs.
    This being a 7 day old unit,i brought it back and got a 2nd unit from
    where i bought it..and this had done the same thing...and when it
    freezes the screen,i can not do anything at all with it..none of the
    controls will do anything..... i have to disconnect the dc cord and
    rebot the unit and everything is fine again.
    I again called the Magellen company,but by phone this time..and they
    again said that i should repack it and sent it to them to troubleshoot,
    and they said that they never heard of this happening...but i am 2 for
    2 with this problem.
    Has anyone else had this happen?????
    Is it just a glitch, and i will have to live with it???
    THANK YOU FOR ANY HELP THAT YOU MAY HAVE
     
    , Jul 14, 2005
    #1
    1. Advertisements

  2. lostparts Guest

    Do a Google search on RM700 Freeze up's see if someone has had the problem
    and maybe a work around.
    <> wrote in message
    news:...
    :I love my RM700..but i am on my second unit in less than 24 days.
    : Both units freeze up(usually while on the 3d turning screen..but not
    : always...I e mailed Magellan about the problem with my first unit and
    : they gave me a Return Authorization number and told me to send it to
    : them for repairs.
    : This being a 7 day old unit,i brought it back and got a 2nd unit from
    : where i bought it..and this had done the same thing...and when it
    : freezes the screen,i can not do anything at all with it..none of the
    : controls will do anything..... i have to disconnect the dc cord and
    : rebot the unit and everything is fine again.
    : I again called the Magellen company,but by phone this time..and they
    : again said that i should repack it and sent it to them to troubleshoot,
    : and they said that they never heard of this happening...but i am 2 for
    : 2 with this problem.
    : Has anyone else had this happen?????
    : Is it just a glitch, and i will have to live with it???
    : THANK YOU FOR ANY HELP THAT YOU MAY HAVE
    :
     
    lostparts, Jul 14, 2005
    #2
    1. Advertisements

  3. tjp Guest

    Seems very strange that 2 units would be exhibiting the same problem.
    Have you looked at your car? Perhaps the power connector on your car has a
    loose connection? How about you car's charging system? Do you have a
    voltmeter you can hook up to it? I believe Magellan states it needs 9 to 12
    volts. I can't see your car working if it it was below 9 volts. But maybe
    you are running at 13 volts.



    <> wrote in message
    news:...
    >I love my RM700..but i am on my second unit in less than 24 days.
    > Both units freeze up(usually while on the 3d turning screen..but not
    > always...I e mailed Magellan about the problem with my first unit and
    > they gave me a Return Authorization number and told me to send it to
    > them for repairs.
    > This being a 7 day old unit,i brought it back and got a 2nd unit from
    > where i bought it..and this had done the same thing...and when it
    > freezes the screen,i can not do anything at all with it..none of the
    > controls will do anything..... i have to disconnect the dc cord and
    > rebot the unit and everything is fine again.
    > I again called the Magellen company,but by phone this time..and they
    > again said that i should repack it and sent it to them to troubleshoot,
    > and they said that they never heard of this happening...but i am 2 for
    > 2 with this problem.
    > Has anyone else had this happen?????
    > Is it just a glitch, and i will have to live with it???
    > THANK YOU FOR ANY HELP THAT YOU MAY HAVE
    >
     
    tjp, Jul 16, 2005
    #3
  4. tjp Guest

    Seems very strange that 2 units would be exhibiting the same problem.
    Have you looked at your car? Perhaps the power connector on your car has a
    loose connection? How about you car's charging system? Do you have a
    voltmeter you can hook up to it? I believe Magellan states it needs 9 to 12
    volts. I can't see your car working if it it was below 9 volts. But maybe
    you are running at 13 volts.



    <> wrote in message
    news:...
    >I love my RM700..but i am on my second unit in less than 24 days.
    > Both units freeze up(usually while on the 3d turning screen..but not
    > always...I e mailed Magellan about the problem with my first unit and
    > they gave me a Return Authorization number and told me to send it to
    > them for repairs.
    > This being a 7 day old unit,i brought it back and got a 2nd unit from
    > where i bought it..and this had done the same thing...and when it
    > freezes the screen,i can not do anything at all with it..none of the
    > controls will do anything..... i have to disconnect the dc cord and
    > rebot the unit and everything is fine again.
    > I again called the Magellen company,but by phone this time..and they
    > again said that i should repack it and sent it to them to troubleshoot,
    > and they said that they never heard of this happening...but i am 2 for
    > 2 with this problem.
    > Has anyone else had this happen?????
    > Is it just a glitch, and i will have to live with it???
    > THANK YOU FOR ANY HELP THAT YOU MAY HAVE
    >
     
    tjp, Jul 16, 2005
    #4
  5. E M Guest

    hi

    Our Roadmate 700 as well freezes up at times :( Alll We do is disconnect
    the power cord and turn it back on and the machine works OK, but I know it
    isnt THE solution for such a problem.


    <> wrote in message
    news:...
    >I love my RM700..but i am on my second unit in less than 24 days.
    > Both units freeze up(usually while on the 3d turning screen..but not
    > always...I e mailed Magellan about the problem with my first unit and
    > they gave me a Return Authorization number and told me to send it to
    > them for repairs.
    > This being a 7 day old unit,i brought it back and got a 2nd unit from
    > where i bought it..and this had done the same thing...and when it
    > freezes the screen,i can not do anything at all with it..none of the
    > controls will do anything..... i have to disconnect the dc cord and
    > rebot the unit and everything is fine again.
    > I again called the Magellen company,but by phone this time..and they
    > again said that i should repack it and sent it to them to troubleshoot,
    > and they said that they never heard of this happening...but i am 2 for
    > 2 with this problem.
    > Has anyone else had this happen?????
    > Is it just a glitch, and i will have to live with it???
    > THANK YOU FOR ANY HELP THAT YOU MAY HAVE
    >
     
    E M, Jul 26, 2005
    #5
  6. Guest

    E M wrote:
    > hi
    >
    > Our Roadmate 700 as well freezes up at times :( Alll We do is disconnect
    > the power cord and turn it back on and the machine works OK, but I know it
    > isnt THE solution for such a problem.
    >
    >

    i am on my third unit and this has locked up and froze once or twice
    already in the last week or so....i wish that Magellan would own up to
    the situation and just make a note in the manual to unplug power and
    reboot..i am sure we are not the only one with this problem.
    I tried out a Garmin C330 ..and right in the manual,it has instructions
    on what to do if it freezes up.
    I have tried the Garmin 2620 and the Lowrance i500 and i still like the
    Magellan the best.
     
    , Jul 27, 2005
    #6
  7. E M Guest

    <<I have tried the Garmin 2620 and the Lowrance i500 and i still like the
    Magellan the best.>>


    We love the Magellan Roadmate 700. But I didnt try the others. Why do you
    like the Magellan the best??












    <> wrote in message
    news:...
    >
    >
    > E M wrote:
    >> hi
    >>
    >> Our Roadmate 700 as well freezes up at times :( Alll We do is disconnect
    >> the power cord and turn it back on and the machine works OK, but I know
    >> it
    >> isnt THE solution for such a problem.
    >>
    >>

    > i am on my third unit and this has locked up and froze once or twice
    > already in the last week or so....i wish that Magellan would own up to
    > the situation and just make a note in the manual to unplug power and
    > reboot..i am sure we are not the only one with this problem.
    > I tried out a Garmin C330 ..and right in the manual,it has instructions
    > on what to do if it freezes up.
    > I have tried the Garmin 2620 and the Lowrance i500 and i still like the
    > Magellan the best.
    >
     
    E M, Jul 27, 2005
    #7
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. allory

    Magellan RoadMate 700 and 500

    allory, Oct 21, 2003, in forum: General GPS
    Replies:
    4
    Views:
    351
    Skramblr
    Nov 1, 2003
  2. RoadMate700

    Magellan Roadmate 700 deal

    RoadMate700, Dec 6, 2003, in forum: General GPS
    Replies:
    0
    Views:
    285
    RoadMate700
    Dec 6, 2003
  3. Allory Deiss
    Replies:
    0
    Views:
    330
    Allory Deiss
    May 19, 2004
  4. Chuck

    How to update Magellan Roadmate 700

    Chuck, Oct 1, 2004, in forum: General GPS
    Replies:
    0
    Views:
    312
    Chuck
    Oct 1, 2004
  5. Jeff Hansman

    Magellan Roadmate 700

    Jeff Hansman, Nov 14, 2004, in forum: General GPS
    Replies:
    2
    Views:
    287
    Jeff Hansman
    Nov 16, 2004
Loading...

Share This Page