GPS Forums


Reply
Thread Tools Display Modes

Explorist 210 firmware update ?

 
 
S. Caro
Guest
Posts: n/a
 
      07-02-2006, 05:29 PM

I've had my Explorist 210 for about 3 weeks now.

I've been trying the 'update firmware' option that is
available on the included installation CD.

Up until recently, I was getting an error page indicating
that the Magellan site was under maintenance. This
happened day and night, weekdays weekends for most of
the three weeks.

Today I see they seem to have finished updating the server
and now, the Magellan support page opens... But there is
no mention of firmware upgrades.

When I select my model, all that is available are manuals
in PDF format. Again, there is no mention of firmware upgrades.

My current firmware version is Rev 3.1.75. By the absence of
any reference to downloading firmware on the Magellan support
site, am I correct in assuming there are no upgrades ?



Is
 
Reply With Quote
 
 
 
 
Jack Erbes
Guest
Posts: n/a
 
      07-02-2006, 07:22 PM
S. Caro wrote:

> I've had my Explorist 210 for about 3 weeks now.
>
> I've been trying the 'update firmware' option that is
> available on the included installation CD.
>
> Up until recently, I was getting an error page indicating
> that the Magellan site was under maintenance. This
> happened day and night, weekdays weekends for most of
> the three weeks.
>
> Today I see they seem to have finished updating the server
> and now, the Magellan support page opens... But there is
> no mention of firmware upgrades.
>
> When I select my model, all that is available are manuals
> in PDF format. Again, there is no mention of firmware upgrades.
>
> My current firmware version is Rev 3.1.75. By the absence of
> any reference to downloading firmware on the Magellan support
> site, am I correct in assuming there are no upgrades ?


I would say you are correct. You problems with doing the update from
the CD probably relate to Magellan recently publishing a new web page.
I can no longer see the pages in Mozilla (but IE will work) so I assume
they did not get a perfect implementation on the links from the old page
to the new.

Jack

--
Jack Erbes in Ellsworth, Maine, USA (jackerbes at adelphia dot net)
(also receiving email at jacker at midmaine dot com)
 
Reply With Quote
 
 
 
 
SirhcD
Guest
Posts: n/a
 
      07-03-2006, 01:05 AM
On Sun, 02 Jul 2006 12:29:17 -0500, "S. Caro" <(E-Mail Removed)>
wrote:

>
>I've had my Explorist 210 for about 3 weeks now.

<SNIP>
>My current firmware version is Rev 3.1.75. By the absence of
>any reference to downloading firmware on the Magellan support
>site, am I correct in assuming there are no upgrades ?


You are correct. I also have a eX210...It as well is at rev 3.1.75
and works just fine.

SirhcD
 
Reply With Quote
 
S. Caro
Guest
Posts: n/a
 
      07-03-2006, 01:24 AM
SirhcD wrote:

>
> You are correct. I also have a eX210...It as well is at rev 3.1.75
> and works just fine.



OK thanks.. My unit runs fine also. I just wanted to know if there
WAS a firmware update :-)


 
Reply With Quote
 
S. Caro
Guest
Posts: n/a
 
      07-03-2006, 01:27 AM
Jack Erbes wrote:

> S. Caro wrote
>> My current firmware version is Rev 3.1.75. By the absence of
>> any reference to downloading firmware on the Magellan support
>> site, am I correct in assuming there are no upgrades ?

>
> I would say you are correct. You problems with doing the update from
> the CD probably relate to Magellan recently publishing a new web page.


OK.. That explains it.

You'd think they would have made sure the links on all the
bundled CDs that were shipped with their products would be in
order first :-)

> I can no longer see the pages in Mozilla (but IE will work) so I assume
> they did not get a perfect implementation on the links from the old page
> to the new.


I can see the pages in Mozilla.. Under Linux no less..


 
Reply With Quote
 
Phil Wheeler
Guest
Posts: n/a
 
      07-03-2006, 02:02 AM
S. Caro wrote:
> SirhcD wrote:
>
>
>>You are correct. I also have a eX210...It as well is at rev 3.1.75
>>and works just fine.

>
>
>
> OK thanks.. My unit runs fine also. I just wanted to know if there
> WAS a firmware update :-)
>
>



I'm curious: Used an Exploris 200 some time ago, and it didn't
seem to have a serial port. Does the 210?

Phil
 
Reply With Quote
 
S. Caro
Guest
Posts: n/a
 
      07-03-2006, 02:25 AM
Phil Wheeler wrote:

> I'm curious: Used an Exploris 200 some time ago, and it didn't
> seem to have a serial port. Does the 210?


The 210 comes with a USB cable.

You can use it for file transfer (maps, routes, POI's etc) or
as a NMEA data source for computer based nav programs.

One nice thing is that when the unit is connected to a
computer USB port, it's powered by the computer. You
don't have to worry about batteries.




 
Reply With Quote
 
Jack Erbes
Guest
Posts: n/a
 
      07-03-2006, 02:45 AM
S. Caro wrote:

<snip>
> I can see the pages in Mozilla.. Under Linux no less..
>


Hmmm... Must by the big, easy to see, fonts I'm using on my laptop.

Thanks for the info.

Jack

--
Jack Erbes in Ellsworth, Maine, USA (jackerbes at adelphia dot net)
(also receiving email at jacker at midmaine dot com)
 
Reply With Quote
 
Phil Wheeler
Guest
Posts: n/a
 
      07-03-2006, 02:53 AM
S. Caro wrote:
> Phil Wheeler wrote:
>
>
>>I'm curious: Used an Exploris 200 some time ago, and it didn't
>>seem to have a serial port. Does the 210?

>
>
> The 210 comes with a USB cable.
>
> You can use it for file transfer (maps, routes, POI's etc) or
> as a NMEA data source for computer based nav programs.
>
> One nice thing is that when the unit is connected to a
> computer USB port, it's powered by the computer. You
> don't have to worry about batteries.
>
>


Ditto for the newer Garmins (60Cx for example).
 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OK to use Euro eXplorist 500 firmware in a North American eXplorist?? Jim Townsend Magellan GPS 7 11-06-2007 01:04 PM
Re: New firmware for the Explorist 210 - about time!!! TheClyde Magellan GPS 0 01-23-2007 07:40 PM
Re: New firmware for the Explorist 210 - about time!!! Ralph Magellan GPS 2 12-07-2006 10:54 PM
Re: New firmware for the Explorist 210 - about time!!! Jim Townsend Magellan GPS 1 12-06-2006 01:27 AM
Re: New firmware for the Explorist 210 - about time!!! Jim Townsend General GPS Discussion 0 12-05-2006 03:30 PM


All times are GMT. The time now is 09:30 AM.